You have no items in your shopping cart.
Sunday, 18 April 2021 4:08:46 PM

Failed to read bus

2 months ago
#13652 Quote
Hello there,
I need your support. I have a MANAGER 30 KIT BMS. It worked perfectly. As I mount it after several change of the program via BT connection and my iPhone I had once the following message : Failed to read bus / Failed to program : Read stage error : Autoscan timed out. you can find pictures on my DropBox since I can't reach the system.
I tried to re-pair several time the BT, ok. I tried to reload old version of my configuration and I can't program anything. I can't even load with redvision app. I tried to shuddown several time, plug/unplug rj54. You see on the pictures the RBus node infos on the display. Thank you for your support, and best regards from the cold Switzerland :)
2 months ago
#13658 Quote
Hi Thierry,
Thanks for your post and your pictures.

What I will get you to try first is based on your phone rather than the Redvision screen itself.
We first look at deleting the Redvision apps, data associated with it and also any bluetooth pairings too. After this, ensure iOS is all up to date with the latest revision and then power cycle your phone. After this, please re-install both Redvision apps and try to re-pair to the Redvision screen, but only through the Redvision apps, not your phone's bluetooth menu.

If still having some issues from here, I would ask you to try (if possible) another phone and see if will connect properly. You can email them the configuration for them to try and upload from there.

Give those things a go first Thierry and if still issues after all that, please let us know.

Best regards,
2 months ago
#13665 Quote
Thank you Andrew
I will try this as soon as possible. For your information I am in Switzerland and the App is not on the Swiss Apple Store that's why I have a second old iPhone with an Australian App Store and the App nor the iOS was up to date and there is no SIM on the phone. I have contact with Marco in Italy to try to fix this and have the App on the AppleStore, at the moment without success.
Best Regards
one month ago
#13675 Quote
Hello Andrew, I tried to re-install the App, change on my new iPhone (now new on the Swiss AppStore) and ... on a Androide Phone. It does not work. I changed all the RJ45 cables, not working. I disconnected the devices one after the other and it works without the distribution box (DB) Only with the DMS, battery monitoring and display. I changes the fuse of the DB and still not working. Any Idea what happened on the DB ? Thanks for your support. Best Regards, Thierry

some pict without the DB
one month ago
#13685 Quote
Hi Thierry,
Thanks for sending that extra information and pictures through.

I am wondering if you are able to also post some pics of your setup (wiring showing distribution box, screen and BMS connections) also? The more detail the better is always good!

I am thinking if there is just an issue with the R-Bus connections somewhere making this issue.

Thanks again,
one month ago
#13686 Quote
Dear Andrew,

As I said, I tried to change all RJ45 cables and It works without the DB (means connection Display - BMS —> ok). As soon as I put the DB in serial it bugs. Can be the RJ45 of the DMS defect or the DMS firmware. Any reset possibility ? Any other solution to try ?

Here some other pict. Behind the Display the terminating resistor is pluged :)

Thanks again, Thierry


one month ago
#13687 Quote
Hi Thierry,
Thanks for sending those extra pics through too!

The next thing I'd like to try is with the R-BUS cables, making some changes. If you are able to swap the cable going from the BMS to the DB, then use that to connect DB to splitter instead. This will then take the BMS out of the system and we only have a connection between the Display and DB.

I am wondering if one of these cables is perhaps faulty (has a break in the wire etc) or is of the wrong type. Did you use the cables out of our normal kit or purchase some separate ones too? We generally use CAT5E type Ethernet cables, with a straight through pin-out (not cross-over type).

See how you go with that Thierry and let me know!
one month ago
#13697 Quote
Hi Andrew, I'm going to the workshop today and last night I actually thought that it could only come from the cables or the splitter. I took 1 spare cable to try that too. I'm also trying to isolate the DMS to see. Thanks and I'll let you know.
Regards. Thierry
one month ago
#13700 Quote
Hi Andrew, just to inform that it works, but it was not the cable and somehow strange with the software. With an old Balckberry I managed to upload « TVMS ... » after several try. I send you tomorrow more information and all the pics I did as soon as I am on my computer. Regards, Thierry
one month ago
#13703 Quote
Thanks Thierry,

Keep me updated when you can :)

Afterpay. Shop now. Pay later.

All you need to apply is to have a debit or credit card, to be over 18 years of age, and to be a resident of Australia.

Late fees and additional eligibility criteria apply. The first payment may be due at the time of purchase. For complete terms visit